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2 Introduction 
Nutiteq mobile mapping library is designed to enable adding custom slippy maps to mobile applications. 

To get started, we assume that you know some basics of Android development, at least how to compile 
basic applications; there are a lot of good tutorials about it, e.g. 
http://developer.android.com/guide/tutorials/hello-world.html  

Following tutorial includes only most basic functions and examples of the library, full library has much 
more features and options, see Nutiteq Maps Lib Developer guide and on-line javadoc from 
www.nutiteq.com > Developer  section to have full overview of functionality. 

Google Android SDK package has also bundled Google Maps External Library package 
(com.google.android.maps), which provides also basic mapping features. This library is quite similar to 
Nutiteq library, following is feature comparison between Nutiteq and Google Maps library: 

 Nutiteq Library Google Maps library 

Map sources OpenStreetMap  
CloudMade 
Navteq (MapTP) 
DeCarta 
DigitalGlobe (satellite and aerial)  
BLOM Urbex (aerial) 
Bing (Microsoft) Maps 
Yahoo! Maps  
WMS API 
TMS API 
Ka-Map API  
Custom map sources 

Google Maps 
Google Aerial images 
Google StreetView 

Offline maps, caching Caching in memory 
Permanent caching in SD card 
Pre-loaded maps from SD card 
Pre-loaded maps from  
application installer package 

Caching in memory only 

Projections WGS84,  
Spherical Mercator 
Mercator 
Custom projections 

WGS84 for data 
Spherical Mercator for maps 

Map overlays  Points 
User dynamic location  
Lines 
Polygons 
KML overlays with points, lines 
and polygons 
Raster overlays 

Points  
User dynamic location 

Routing service Included, using OSM-based ( No 

http://developer.android.com/guide/tutorials/hello-world.html
http://www.nutiteq.com/
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CloudMade, Yournavigation) or 
own custom servers based on 
OpenLS 

Geocoding (address search) 
service 

Included, using OSM-based ( 
CloudMade, Namefinder) or own 
custom servers 

No 

Visual indicators Customizable DownloadDisplay 
Customizable ZoomDisplay 
Customizable Copyright overlay 

None 

API Compatibility with other 
mobile platforms 

Java ME (J2ME) 
RIM BlackBerry 
Symbian (with J2ME) 

None 

Licensing terms Commercial royalty-free licenses 
available from Nutiteq. 
Free for GPL applications and 
developers. Commercial support 
available. Source code available 
for licensees. 

Free for most applications, 
expensive license needed for 
some application types (e.g. fleet 
management). No official 
commercial support, no source 
code available. 

 

 

2.1 Document history 

Who When Rev What 

JaakL 07.12.2009 1.0.2 First Android-specific version, for lib version 1.0.2. 
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3 Simple Map 
Following are steps for your “Hello world” type of Android interactive mapping application called Hello 
map. We assume that you have installed Android SDK, Eclipse IDE (I use 3.4.2) with compatible Android 

Development Tools (ADT) Plug-in for Eclipse. 

1. Create new Android  project: in Eclipse, select File > New project >  Android, Android Project. 

Let’s call it hello_map.  Pick any existing Android Build Target you have a working emulator for.  I 

use Android 1.6. (MGMaps lib works with  Android SDK 1.1 and up.) 

2. Under Properties section:  name your application to Hello map and use com.tutorial as a 

package name.  Also make sure, that Create Activity is checked and use HelloMap as name of the 

activity class. Click Finish 

3. You should end up with the default Android project code: 

package com.tutorial; 

 

import  android.app.Activity; 

import  android.os.Bundle; 

 

public class HelloMap extends Activity {  

    /** Called when the activity is first created. */ 

    @Override 

    public void onCreate(Bundle savedInstanceState) { 

        super.onCreate(savedInstanceState); 

        setContentView(R.layout.main); 

    }  

}  

4. Now configure Android Manifest  file. Open AndroidManifest.xml  file and go to Permissions tab. 

We need to add two permissions here. Under Android Manifest Permissions Click Add and pick 

Uses Permission from the list. Under Attributes for Uses Permission pick 

android.permission.INTERNET . Using the same steps  add the second permission called 

android.permission.ACCESS_FINE_LOCATION . Save the file. 

5. To run your code in the emulator: right-click project, select Run As > Android Application. 

Android phone emulator window should be opened with application running, just text “Hello 

World, Hellomap!”. So far so good, but there is yet no map image yet? We’ll add it with the next 

steps. 

6. Add Nutiteq Library JAR to the project. Download from www.nutiteq.com >Developer > 

Downloads Android library package and unzip it. Copy android_maps_lib-xxx.jar  file to project’s 

directory in Eclipse package browser, right-click to the file, and select Build Path > Add to Build 

Path. Eclipse should show now the library JAR in “Referenced Libraries” group in project explorer 

window.  

7. One more step is needed here to ensure that necessary mapping JAR code will be also in your 

application JAR file: right-click project, select Build Path > Configure Build Path; select now tab 

http://www.nutiteq.com/
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“Order and Export”; here android_maps_lib-xxx.jar should be  listed (probably as the last item), 

make it selected and click OK. 

8. Now modify your HelloMap.java to have a few extra lines needed for the actual map. New lines 

are highlighted: 

package com.tutorial; 

 

import  com.nutiteq.BasicMapComponent; 

import  com.nutiteq.android.MapView; 

import  com.nutiteq.components.WgsPoint; 

import  com.nutiteq.controls.AndroidKeysHandler; 

import  com.nutiteq.maps.CloudMade; 

import  com.nutiteq.ui.ThreadDrivenPanning; 

 

import  android.app.Activity; 

import  android.os.Bundle; 

import  android.widget.RelativeLayout; 

 

public class HelloMap extends Activity {  

  

 private MapView mapView; 

 private BasicMapComponent mapComponent; 

  

    /** Called when the activity is first created. */ 

    @Override 

    public void onCreate(Bundle savedInstanceState) { 

        super.onCreate(savedInstanceState); 

         

        mapComponent = new BasicMapComponent("tutorial", "Nutiteq", "Android Mapper", 1, 1,                   

    new WgsPoint(24.764580, 59.437420), 10); 

        mapComponent.setMap(new CloudMade("B37E70903EB540C1A07B3437AFA5DF2E", 64, 1)); 

        mapComponent.setPanningStrategy(new ThreadDrivenPanning()); 

        mapComponent.setControlKeysHandler(new AndroidKeysHandler()); 

        mapComponent.startMapping(); 

         

        mapView = new MapView(this, mapComponent); 

         

        final  RelativeLayout relativeLayout = new RelativeLayout(this); 

        setContentView(relativeLayout); 

         

        final  RelativeLayout.LayoutParams mapViewLayoutParams = new RelativeLayout.LayoutParams( 

                RelativeLayout.LayoutParams.FILL_PARENT, RelativeLayout.LayoutParams.FILL_PARENT); 

        relativeLayout.addView(mapView, mapViewLayoutParams);   

    }  
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9. Let’s take a brief look into added code:  

a. First we have imports, references to mapping library classes which are used and Android 

RelativeLayout widget where we start displaying our content. 

b. Then we define MapView and BasicMapComponent local variables. These are the two 

key objects to manipulate map. 

c. Then we create new BasicMapComponent object. This is the main map object you deal 

with. The constructor parameters are: 

i. license key. “tutorial” works if you use default Vendor and Application names 

like in the tutorial, but for your own application you should generate own key in 

Nutiteq.com homepage (you have to register first, and then from Developers  

section you’ll find My apps page). 

ii. Vendor name used by library for license check. 

iii. Application name used by library for license check. 

iv. Maximum size of the map (width, height).Those parameter values are not 

relevant for Android MapView (that’s why they are set to 1x1 in our example).  

On Android map size is set by View (MapView parameters) and not by 

mapComponent parameters.  

v. initial map center location (24.764580 E, 59.437420 N) as WGS84 decimal 

coordinates. Btw, these numbers are for Tallinn in Estonia 

vi. initial zoom (10). Zoom = 0 means whole world and maximum zoom for OSM is 

18. 

d. Then we create new MapView and add MapComponent to it as a parameter. This is the 

Android View element what is shown on the screen. 

e. Finally, we create a new RelativeLayout and add mapView in it. 

10. Now let’s run it again. Pick Run As > Android Application. You should see following screen. You 

can pan the map by clicking and dragging with the mouse cursor. You cannot zoom in/out the 

map, as the definition of Zoom control keys comes next. 
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11. Now you can also run your application in the phone. Connect your device to PC with the USB 

cable and make sure that USB driver is installed and USB debugging is enabled on the device. 

4 Zoom Controls 
To add zoom controls to the map insert the following lines into your code (right after the line that 
creates new MapView – new lines are marked with gray). Note that we are using Android built-in 
ZoomControl widgets. Also Nutiteq library has own touchable zoom controls, but using Android widget 
gives better consistency for common Android UI. 

public class AndroidMapper extends Activity {  

 

private ZoomControls zoomControls; 

 

/** Called when the activity is first created. */ 

    @Override 

    public void onCreate(Bundle savedInstanceState) { 

        super.onCreate(savedInstanceState); 

é 

        mapView = new MapView(this, mapComponent); 

         

        //Add ZoomControls 

        zoomControls = new ZoomControls(this); 

        zoomControls.setOnZoomInClickListener(new View.OnClickListener() { 

          public void onClick(final View v) { 

            mapComponent.zoomIn(); 

          }  

        });  

        zoomControls.setOnZoomOutClickListener(new View.OnClickListener() { 

          public void onClick(final View v) { 
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            mapComponent.zoomOut(); 

          }  

        });  

         

        final RelativeLayout relativeLayout = new RelativeLayout(this); 

        setContentView(relativeLayout); 

         

        // MapView 

        final RelativeLayout.LayoutParams mapViewLayoutParams = new RelativeLayout.LayoutParams( 

                RelativeLayout.LayoutParams.FILL_PARENT, RelativeLayout.LayoutParams.FILL_PARENT); 

        relativeLayout.addView(mapView, mapViewLayoutParams);   

         

        //Add Zoom controls View to the RelativeLayout  

        final RelativeLayout.LayoutParams zoomControlsLayoutParams = new RelativeLayout.LayoutParams( 

                RelativeLayout.LayoutParams.WRAP_CONTENT, RelativeLayout.LayoutParams.WRAP_CONTENT); 

            zoomControlsLayoutParams.addRule(RelativeLayout.ALIGN_PARENT_BOTTOM); 

            zoomControlsLayoutParams.addRule(RelativeLayout.CENTER_HORIZONTAL); 

            relativeLayout.addView(zoomControls, zoomControlsLayoutParams); 

 

5 Correct way to close the program 
You could have noticed, that the program sometimes crashes with an error message during closing or 
restarting, after you have pressed Back and tried to run the application again. To fix that we have to do 
some housecleaning. We override the default onDestroy()  method and we will also use a custom 
boolean variable onRetainCalled  to check if we should clean the mapComponent or not. Add the 
following lines to your code (new lines are marked with gray): 

... 

private boolean onRetainCalled; 

 

    /** Called when the activity is first created. */ 

    @Override 

    public void onCreate(Bundle savedInstanceState) { 

        super.onCreate(savedInstanceState); 

  

 onRetainCalled = false; 

 ... 

 

        //Zoom controls 

        final RelativeLayout.LayoutParams zoomControlsLayoutParams = new  RelativeLayout.LayoutParams( 

                RelativeLayout.LayoutParams.WRAP_CONTENT,  

 RelativeLayout.LayoutParams.WRAP_CONTENT); 

            zoomControlsLayoutParams.addRule(RelativeLayout.ALIGN_PARENT_BOTTOM); 

            zoomControlsLayoutParams.addRule(RelativeLayout.CENTER_HORIZONTAL); 

            relativeLayout.addView(zoomControls, zoomControlsLayoutParams); 

    }  

        

    @Override 

    public Object onRetainNonConfigurationInstance() { 

      onRetainCalled = true; 

      return mapComponent; 

    }  

         

    @Override 
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    protected void onDestroy() { 

      super.onDestroy(); 

      if (mapView != null) { 

          mapView.clean(); 

          mapView = null; 

        }  

     

      if (!onRetainCalled) { 

          mapComponent.stopMapping(); 

          mapComponent = null; 

        }  

    }  

}  

 

6 Show GPS location on map 
Let’s try to pan the map to your current GPS location. There are two options for it: 

a) Use Android Location API, get your location coordinates and add a point (Place, Polygon or Line) 
on map for that,  

b) Use Nutiteq library built-in GPS positioning support. Following describes the latter approach, as it 
has proper dynamic object for user location display. 

 

1. Import location packages to the source file 

import  com.nutiteq.location.LocationMarker; 

import  com.nutiteq.location.LocationSource; 

import  com.nutiteq.location.NutiteqLocationMarker; 

import  com.nutiteq.location.providers.AndroidGPSProvider; 

2. Define location source and define special type of object (LocationMarker) on map, to show GPS 

location. Note that an image is needed to show the marker. We use a .PNG image with 

resolution of 10x17 pixels. You need to copy your image to your project, to directory 

res/drawable/yourGPSimage.png.  

Then insert the following lines right below the Zoom controls definition. 

// Zoom controls 

é 

// GPS Location 

 final  LocationSource locationSource = new AndroidGPSProvider( 

(LocationManager) getSystemService(Context.LOCATION_SERVICE), 1000L); 

final  LocationMarker marker = new NutiteqLocationMarker(new PlaceIcon(Utils 

              .createImage("/res/drawable/gps_marker.png"), 5, 17), 3000, true); 

locationSource.setLocationMarker(marker); 

mapComponent.setLocationSource(locationSource); 

3. Run your changed code. Note that you have to define 

android.permission.ACCESS_FINE_LOCATION  permission in AndroidManifest.xml file to get 
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location information. To get the GPS coordinates inside the emulator you need to switch 

your Eclipse UI layout to DDMS (Dalvik Debug Monitor Server). This layout contains the 

debugging tools for Android. From here you can send the GPS coordinates to emulator by 

going under Emulator Control > Location Controls and pressing the Send button on the 

Manual tab. The default location is Google Headquarters in California, but you can change 

coordinates using Longitude and Latitude fields on the Manual tab.  

4. On real devices you may be lucky to get your actual GPS coordinates. One thing what you will 

notice is that first GPS location fix takes time – depending on your GPS, A-GPS service 

provider, physical location (indoors/outdoors) and last location fix it will take from 30 

seconds to several minutes.  

7 Adding KML data to the map 
 

Google geodata standard file format (KML) data can be read on-line by the Nutiteq mapping library. You 
may already have a web service which utilizes the format for Google Maps web or Google Earth, now you 
can just publish it on the mobile. Nutiteq mapping Lib currently supports following KML elements: points, 
lines and polygons, also style elements are supported, so you can have your custom markers. 
www.nutiteq.com Developer section has a document describing which KML elements are exactly 
supported. 

 

1. Import KML package to the Midlet 

import  com.nutiteq.kml.KmlUrlReader; 

2. Add dynamic KML layer to the map, with Panoramio popular images.  

 mapComponent.addKmlService(new KmlUrlReader( 

                "http://www.panoramio.com/panoramio.kml?LANG=en_US.utf8&", true)); 

3. In DDMS LogCat window (shown in IDE, but not in real device) you should see debug log from 

device or emulator. Notice that the URL request will have also some additional parameters 

automatically added to the define URL. Smart servers will use at least BBOX (this means 

Bounding  Box of the current map view) parameter, and will return elements only elements 

inside of given area. Best servers should use also max element (maximum number of expected 

Placemarks) and may use zoom layering/clustering based on the current zoom parameter. You 

see something like: 

Debug > Downloading 
http://www.panoramio.com/panoramio.kml?LANG=en_US.utf8&BBOX=24.713058,59.424473,24.816055,59.450659&zoom=14
&max=10 

 

http://www.nutiteq.com/
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4. If you move or zoom the map, you see from debug log that KML request is done again (because 

we defined parameter needsUpdateAfterRead=true). If user moves map a lot, then there can be 

a lot of on-line re-readings, which means a lot of traffic (which is good if you happen to be 

mobile operator who charges for it, but it is no good for users). So keep this in mind. 

Some notes for creation of compatible KML files: 

 Only UTF-8 charset is supported 

 KML should not have more than about 20 elements (placemarks). With real phones the memory 

limit may be quite tight. This is why BBOX and max parameters are used. Number of elements 

depends also on type of elements: complex polygons take much more memory than points. 

 Mobile mapping lib does not support all KML features, e.g. KMZ, link elements, refresh, more 

advanced style parameters (e.g. scale of icons) of raster overlays. We plan to add at least some 

of these in next releases, possibly also enhance rendering of more complex elements and styles. 

Also client-side caching will be enhanced further (currently only icon images are cached in RMS). 

Please let us know what features do you miss most. 

8 Full Hello Map listing 
 

Following is final listing of HelloMap.java, including all tutorial steps : 

package com.tutorial; 

 

import com.nutiteq.BasicMapComponent; 

import com.nutiteq.android.MapView; 

//import com.nutiteq.cache.MemoryCache; 

import com.nutiteq.components.PlaceIcon; 

import com.nutiteq.components.WgsPoint; 

import com.nutiteq.controls.AndroidKeysHandler; 

import com.nutiteq.kml.KmlUrlReader; 

import com.nutiteq.location.LocationMarker; 

import com.nutiteq.location.LocationSource; 

import com.nutiteq.location.NutiteqLocationMarker; 

import com.nutiteq.location.providers.AndroidGPSProvider; 

import com.nutiteq.maps.CloudMade; 

import com.nutiteq.ui.ThreadDrivenPanning; 

import com.nutiteq.utils.Utils; 

 

import android.app.Activity; 

import android.content.Context; 

import android.location.LocationManager; 

import android.os.Bundle; 

import android.view.View; 

import android.widget.RelativeLayout; 

import android.widget.ZoomControls; 

 

public class HelloMap extends Activity { 
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 private MapView mapView; 

 private BasicMapComponent mapComponent; 

 private boolean onRetainCalled; 

 private ZoomControls zoomControls; 

  

    /** Called when the activity is first created. */ 

    @Override 

    public void onCreate(Bundle savedInstanceState) { 

        super.onCreate(savedInstanceState); 

         

        onRetainCalled = false; 

 

        mapComponent = new BasicMapComponent("YOUR NUTITEQ KEY", "YOUR COMPANY", "APP NAME", 1, 1, 

  new WgsPoint(24.764580, 59.437420), 10); 

        mapComponent.setMap(new CloudMade("YOUR CLOUDMADE KEY", 64, 1)); 

        mapComponent.setPanningStrategy(new ThreadDrivenPanning()); 

        mapComponent.setControlKeysHandler(new AndroidKeysHandler()); 

        mapComponent.startMapping(); 

         

        mapComponent.addKmlService(new KmlUrlReader( 

                "http://www.panoramio.com/panoramio.kml?LANG=en_US.utf8&", true)); 

              

        mapView = new MapView(this, mapComponent); 

      

  

        //Create new ZoomControls 

        zoomControls = new ZoomControls(this); 

        zoomControls.setOnZoomInClickListener(new View.OnClickListener() { 

          public void onClick(final View v) { 

            mapComponent.zoomIn(); 

          }  

        });  

        zoomControls.setOnZoomOutClickListener(new View.OnClickListener() { 

          public void onClick(final View v) { 

            mapComponent.zoomOut(); 

          }  

        });  

        

        final RelativeLayout relativeLayout = new RelativeLayout(this); 

        setContentView(relativeLayout); 

         

        // MapView 

        final RelativeLayout.LayoutParams mapViewLayoutParams = new RelativeLayout.LayoutParams( 

                RelativeLayout.LayoutParams.FILL_PARENT, RelativeLayout.LayoutParams.FILL_PARENT); 

        relativeLayout.addView(mapView, mapViewLayoutParams);   

         

        //Add Zoom controls to screen 

        final RelativeLayout.LayoutParams zoomControlsLayoutParams = new RelativeLayout.LayoutParams( 

                RelativeLayout.LayoutParams.WRAP_CONTENT, RelativeLayout.LayoutParams.WRAP_CONTENT); 

            zoomControlsLayoutParams.addRule(RelativeLayout.ALIGN_PARENT_BOTTOM); 

            zoomControlsLayoutParams.addRule(RelativeLayout.CENTER_HORIZONTAL); 

            relativeLayout.addView(zoomControls, zoomControlsLayoutParams); 

             

         // GPS Location    

            final LocationSource locationSource = new AndroidGPSProvider( 

              (LocationManager) getSystemService(Context.LOCATION_SERVICE), 1000L); 

            final LocationMarker marker = new NutiteqLocationMarker(new PlaceIcon(Utils 

              .createImage("/res/drawable/gps_marker.png"), 5, 17), 3000, true); 
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            locationSource.setLocationMarker(marker); 

            mapComponent.setLocationSource(locationSource); 

    }  

        

    @Override 

    public Object onRetainNonConfigurationInstance() { 

      onRetainCalled = true; 

      return mapComponent; 

    }  

         

    @Override 

    protected void onDestroy() { 

      super.onDestroy(); 

      if (mapView != null) { 

          mapView.clean(); 

          mapView = null; 

        }  

     

      if (!onRetainCalled) { 

          mapComponent.stopMapping(); 

          mapComponent = null; 

        }  

    }  

}  

9 Next steps: using mapComponent API 
Nutiteq mapping library has many additional features, which enables to draw overlays to map (raster 
and vectors, lines, polygons and points), select different base maps etc. Mainly the features are exposed 
as Java API of the mapComponent object you use, for some features there are public interfaces 
(protocols) what you can implement yourself to customize map more. 

See Nutiteq Mapping Lib API developer guide, Javadoc and example applications’ sources to see how 
mapComponent is used.  

 


